[Solved?] Is AMD K6-2 CPU supported?

Forums Network Management Signal a BUG [Solved?] Is AMD K6-2 CPU supported?

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #42238


    I have a Compaq Presario 2292 machine (AMD K6-2 333MHz / 128MB RAM / 4GB HDD).

    I’m trying to boot the machine using the 1.0beta12 CD-image, but the boot process always ends on the line “Freeing unused kernel memory: 260k freed”. I have tried all the boot options (boot process hangs earlier if I don’t select the “no ACPI” -option), but nothing helps.

    Same behaviour is reported on this thread:

    and the latest post on this thread

    CD-reader and disc are OK, ZS runs fine with Athlon 1GHz machine using the same memory+CD drive+disc.

    Am I right for suspecting that this is a some kind of kernel problem?
    Does anyone have ZS running on AMD K6-2 CPU? If the problem does not lay on the kernel, what may be the problem?

    Please advice…


    OK, this is actually NOT a bug…

    Kernel works fine (probably it has a i386 support), recompiling it for K6-2 doesn’t make a difference. We have a crash upon running init.

    K6-2 machine is a i586 architecture machine, and doesn’t have the CMOV instruction. The libc and gcc utils are builded for a i686 architecture and they use the CMOV-instructions which results to a hang or a kernel panic in i586 machines.

    So AFAIK, all K6(-II/-III) machines and VIA C3 -machines and all the other processor without CMOV-instruction won’t work. This information should be in the “hardware compatibility” list.

    As a feature request, it shouldn’t be impossible to recompile stuff for i586/i386 and someone really should make a howto for it…

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.