[SOLVED]Zeroshell virtualbox guest on win7ult host: Bridging

Forums Network Management ZeroShell [SOLVED]Zeroshell virtualbox guest on win7ult host: Bridging

  • This topic is empty.
Viewing 1 post (of 1 total)
  • Author
  • #43042

    1. Adding both ETHxx and VPNyy to BRIDGEzz
    2. Zeroshell will issue a new MAC for BRIDGEzz (maybe original VPNyy MAC)

    1. Setup Zersohell and bridge (make sure IP’s still work or SSH)
    2. Note BRIDGEzz MAC
    3. Shutdown Zeroshell
    4. Open virtualbox network settings
    5. Set MAC of bridge adaper (for ETHxx) to the MAC of BRIDGEzz

    1. Please consider a “keep ETHxx MAC” option when creating BRIDGEzz
    2. Please use kernel > 2.6.39 and enable “debloat” scheduler options

    Cheers, JW

    [NEXT ISSUE] Configuring zeroshell & win7ult & vpn to allow vpn client to ping lan and visa versa.
    – Arp lan-client works
    – Ping and arp works from within zeroshell
    – VPN settings work (server-bridge, mimic working dd-wrt server settings)
    – No firewall on win7 & client (XP and/or dd-wrt)
    – No ping and no tcp/udp between lan and client(lan)

    Clues anybody?


    Dear all,

    After 3 days of testing and searching I am about to give up. Either this is not possible or I am blind to a very simple error on my side, any help would be much appreciated,..

    Even retuning to the most simple setup I cannot create a working bridge within zeroshell. Test setup:

    -win7ult x64 host with -virtualbox 4.08
    -clean vm, linux2.6 preset, 512mB ram
    -ide, cd ZeroShell-1.0.beta14.iso
    – sata, hda 512mB
    -adapter 1, bridged to Realtec PCI GBE (ETH00, Intel PRO/1000MT)
    – adapter 2, bridged to Marvell Yukon GBE (ETH01, Intel PRO/1000MT)
    [adapter 1 -> lan, adapter 2 -> wan xx.yy.zz.8/29]

    After first start:
    1. In virtualbox shell: change IP of ETH00 to
    2. In Web interface: format hda & create new profile
    3. After reboot with new profile: set ETH IP xx.yy.zz.10
    4. Create BRIDGE00 ETH00 only
    5. Create BRIDGE01 EHH01 only

    So far so good, both ip’s are pingeable from lan & wan, login also works on both.

    BUT now, whatever I do, I cannot bridge any other network within zeroshell without breaking external access to either ETH00 or ETH01.

    This is what I tried so far:
    – add VPN99 to BRIDGE00 -> no more access on
    – add VPN99 to BRIDGE01 -> no more access on xx.yy.zz.10
    – delete and recreate ip settings after creating bridges
    – change virtualbox network card settings
    – start virtualbox as administrator and/or in compatibility mode’s
    – create new VPN00 (working fine to external dd-wrt btw)
    – add VPN00 to bridges one or the other
    – add ETH02 and ETH03 as internal network (internal virtual bridge)
    – add ETH02 to bridge00
    – create BRIDGE03 with ETH03 and VPN99

    One way or the other, as soon as I add a bridge to either ETH00 or ETH01, that interface looses external access,..

    Any idea’s??? Cheers JW (BTW, i can open the box to internet for testing if anybody would like to have a shot at this issue)

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.