Transferring Zeroshell Profile

Forums Network Management ZeroShell Transferring Zeroshell Profile

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #41425

    Hi to all!

    I was wondering if how can i be able to transfer a copy profile of zeroshell from one hard disk to another. I am currently registering user accounts on it, i got almost 400 users registered. Now, i am planning to upgrade the PC i am using as my zeroshell server to a new one (complete CPU set) and i dont want to lose those accounts. Is it possible to install zeroshell on the new CPU then copy the old profile and activate it.


    best regards,



    Yes, you can transfer the profile (data+configuration+logs) from a host to another by using the web interface of Zeroshell.

    There are to possibilities:

    1) From the section [Setup][Profiles] select the profile you want to transfer and then press the button [Backup]. A compressed file will be downloaded on your web client PC. Using this you will have to restore the profile on the other CPU.

    2) Plug an external USB disk and use the button [Copy] to make a copy of the selected profile on this disk. Notice, that in this case, the copy is not compressed and Zeroshell can directly use it as profile without restoring.



    thank you very much sir fulvio..:) i’ll try it today..:)

    best regards,



    Thanks sir fulvio!

    I already have migrated the profile to a new cpu, and procedure number 1 is the best way to do it…:)

    best regards,



    Hi all,

    I am facing a problem with this operation. I am trying both ways (either backup/restore DB or USB copy) and I end up with “Problem with profile copy”.
    I am transferring a profle from a VIA system to an ALIX one. I am doing something wrong?

    Thanks for your help,


    I’m having the same problem.

    Tried Zeroshell on an old PC, really liked it ๐Ÿ˜€ so got an Alix board to transfer on to.

    Alix board is up and running with Zeroshell but when I try to load the backup profile onto the Alix I just get “Error during profile restoring!!!”

    Sad times ๐Ÿ™



    Zeroshell on my ALIX board had ‘Default Profile’ active and the profile I was copying over was also the ‘Default Profile’. After I removed it from Zeroshell on the ALIX board I was able to copy my profile over without a problem!


    Hi, I am a new user of zeroshell, I want to use mainly captive portal and before setting up a lot of users I am trying to save profile, I understand that this should save all configuration as well as users created. I creating new profile, activating, system is rebooting but no config is saved, do you know what could be the reason why config does not save?

    thanks in advance


    Well exactly that you are creating a NEW profile. Which will have nothing in it.

    You need to BACKUP the profile.

    You can then RESTORE the profile.




    I see several times on the forum where people say that when they try to restore a profile through the web-interface, there is a message about error to restore profile (after quite a while).

    I work mainly on the alix platform. These devices are plenty fast enough to unzip a backup file within a matter of seconds normally. I believe the reason that it takes so long before eventually failing (and if you examine the files, they are only partially there), has to do with the time setting on the zeroshell. I have a hunch that there is a message being sent somewhere (possibly com2???) that says “warning: unzipping a file that is newer than the current system time.” The message will have to be repeated for each file that is unzipped and the speed at which it can send the message is likely very slow (possibly because of the rate of the serial interface).

    Last time I needed to do a profile backup/restore, I tried all of the usual tips like deactivating the main profile before restoring and/or copying the original profile and making a backup of the copy. Neither of these tips worked for me and I don’t believe they are necessary steps.

    I believe the true answer is simply setting the time of the zeroshell device to a date/time greater than or equal to the zeroshell device that you are restoring from. I think most zeroshell devices will have the incorrect time until they are on-line long enough to set themselves.

    Lastly, I didn’t have a reason to test my above theory using the web-interface, but I do want to encourage anyone that is nervous about backup/restore that the manual methods are very straight forward and more fool-proof. Here is my alternate strategy if the web-interface option does not work:

    1. create a tar.gz file of the profile that you want to backup (log in through ssh)
    2. sftp the tar.gz file to an alternate host (almost any server/device that you can ssh to would be able to accept the file)
    3. connect your new zeroshell device. set up minimal internet connectivity (takes about 2 minutes)
    4. log in to the new zeroshell device with ssh; use sftp to get the backup file
    5. unzip the backup file into the profiles directory
    6. activate the profile

    Using the above procedure is where I stumbled upon the possible delay in restoring. A debug message is displayed on the screen warning about the time for every file that is being unzipped. I waited for about 15 minutes for the unzip to complete before I got tired of it. I canceled the unzip, set the correct time, and started the unzip again. It took maybe 3 seconds.


    is this procedure valid also if I manually changed some settings (for example VLANs, as we discussed on this forum in the past, look at ) from the shell prompt?
    Does Backup/Restore keeps these settings?
    Thank you!


    @ilNebbioso wrote:

    is this procedure valid also if I manually changed some settings (for example VLANs, as we discussed on this forum in the past? Does Backup/Restore keeps these settings?
    Thank you!

    When I messed with VMware Tools on ZS, I found that anything stored in /Database gets saved when I export the profile. That included any VMware Tools files I put there when following xmas79’s original installation instructions.

    /Database is linked to whatever the active profile directory is. /DB, by comparison, is where these profiles are stored. Anything stored in the beginning of /DB is available to all profiles.

    These days I put VMTools in /DB instead, to avoid polluting individual profiles. But it shows that any customization you do does get exported, as long as you store said customizations in /Database. The actual ZS installation is still on a CD-ROM image, even if that image is on a hard drive or flash partition, so you’re not going to easily corrupt that.


    thank you very much for your reply!

    I already:
    – configured a brand new box with ZS3.0.2
    – exported from v. 1beta15 a backup (without logs)
    – imported backup into the new one
    and I verified *all* settings were keeped (also VLANs).

    I’ll do a onsite test during next evenings, after working time, replacing the 1beta15 box with the new one, but I do not expect any problem.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.