very basic load balancing of two eth… not working

Forums Network Management ZeroShell very basic load balancing of two eth… not working

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #42433

    OK I’m having issues getting this to work. I have two basic ethernet connections I’m trying to balance. At the heart of the issue it seems like nothing is routing through Zeroshell when received over ETH00 (to go out over ETH01 or 03).

    ETH00 ( is the interface that the connections will come in on. I have NAT enabled and it’s successfully issuing DHCP to a laptop attached to it. (It will eventually be a basic wifi router most likely).

    ETH01 ( and ETH03 ( are my two WAN connections I’m trying to balance. Both will be DHCP clients but currently I have the ETH03 configured static.

    My routing table is as follows:

    Destination Netmask Type Metric Gateway Interface Flags State Source Net 0 none ETH03 U Up Auto Net 0 none ETH00 U Up Auto Net 0 none ETH01 U Up Auto Net 0 none VPN99 U Up Auto
    DEFAULT GATEWAY (LB) Net W.1 ETH03 U Up Auto
    DEFAULT GATEWAY (LB) Net W.1 ETH01 U Up Auto

    I think my confusion lies in what Zeroshell be considering to be the default gateway.

    Under NetBalancer rules I just added:

    1 ETH00 * ACCEPT all opt -- in ETH00 out * ->

    though am I correct in thinking that I don’t actually need a Net balancer rules, this is just to get more granular and the basic netload setup will do the balancing relatively close to 50/50 without any rules? or is a basic rule as above required? (either way it seems to have had no impact)

    Under the Net Balancer gateway list itself I have:

    Gateway Status Failure Outage Uptime Up % Weight Traffic Connection
    DEFAULT GATEWAY (ETH03) Active 0 0s 0s - 1 22287 185

    ETH01 (ETH01) Active 0 0s 0s - 1 36872 205

    I’m thinking my balancing rules/etc aren’t the problem–I don’t think this would work as is with just one interface outbound–but this is more of a routing setup problem, I’m just failing to see what that problem is?

    Any help? TIAV


    also question on NAT. do I need NAT enabled on all 3 interfaces, currently I had it enabled on the LAN (ETH0).

    But when I enabled it on ETH01 and ETH03 all of sudden the pings to anything on the ETH01 or ETH03 subnet seem to actually respond.. but anything outside of those respective subnets still nothing…
    i have the open DNS IPs in the DNS forwarder but to eliminate the DNS issues i’m pinging by just IP address anyway… (, for example). when I ping from the [windows] laptop it’s repsonding “Reply from Destination host unreachable.” .. the is my WAN IP for the eth03

    (maybe this is helpful in figuring out what the heck I’m doing wrong… :])


    Firstly remove NAT from your LAN interface (ETH0) and leave it as is on the WAN interfaces. Check if it works now.


    tried that, nothing? :/

    I don’t need to configure a static route for to the WAN interfaces, that’s automatically added by the balancer, yes?


    No it is not added by the balancer. You have to add it either statically or tick the box when you configure the interface, or your dhcp server will send it. I think your problem lies with the NAT you use.
    Please post here some screenshots for the interfaces, the NAT and the Netbalancer. Make sure you need to do NAT, maybe you have modems that are doing the necessary NAT. Also your LAN interface definitely doesn’t need NAT. Also clear any firewall changes you may have done.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.