Forums Network Management ZeroShell VLAN & DHCP

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #42421

    I have set up ZeroShell (LiveCD) as shown in this diagram: http://drop.io/dlrfiles/asset/wireless-vlan3-jpg.
    I got this to work at one time then had to shut down and disconnect ZeroShell from the switch. Upon reconnecting and booting up, I had to reconfigure a few things but just can’t get past the DHCP issue! Connecting with a corporate laptop and RADIUS works as it always has.

    Access point config:
    SSID1: untagged
    SSID2: VLAN 10

    In ZS, the following is set up:
    ETH00: –> port G6/27

    ETH00: –> port G6/28


    DHCP on ETH00

    Switch config is:
    vlan 10
    name GuestNet
    interface GigabitEthernet4/27
    description Wireless access
    switchport trunk allowed vlan 1,10
    switchport mode trunk
    interface GigabitEthernet6/27
    description GuestNet access
    switchport access vlan 10
    switchport mode access
    interface GigabitEthernet6/28
    switchport mode access
    interface Vlan1
    ip address
    interface Vlan10
    ip address
    ip helper-address
    ip default-gateway
    ip http server
    ip http authentication local
    no ip http secure-server

    I put in the passphrase to connect to the AP with the guest laptop and that authenticates fine. Then it tries to get an IP but is never successful.

    Any ideas? Thanks


    assuming that the ZS ETH00 interface( ) is on the native VLAN (not vlan 10) ,if it were a 2960 I’d tell you to try
    to remove the ip address and ip helper address from vlan 10 of the catalyst ….should work …



    ETH00 is connected to a switch port that’s in the VLAN10 so that any traffic originating from SSID2:VLAN10 will flow to the ZS DHCP server, thanks to the ip helper-address on VLAN10… It’s that flow that isn’t working.


    Assuming that c4506 can ping the ZS on the ETH01 interface correctly, could you show us the dhcp configuration you have configured on ZS? Also a screenshot of the interfaces of ZS would be helpful too.
    “ip helper” is not necessary as they are on the same broadcast domain.


    What I tried was to restore the profile that I had saved just before shutting down and disconnecting everything the other day. My XP guest laptop still wouldn’t get an IP. I tried with a Windows 7 laptop and after authenticating with the AP, BINGO! It got an IP from ZS as expected… So I did an ipconfig /release * then ipconfig /flushdns and turned off the wireless on the XP laptop. Rebooted, turned wireless back on and everything works great! Something must have been “stuck” somewhere, probably Microsoft…
    Thanks for everyone’s efforts!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.