VLAN’s, Zeroshell and an Intel Pro 100 Dual NIC

Forums Network Management ZeroShell VLAN’s, Zeroshell and an Intel Pro 100 Dual NIC

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #41386

    I seem to be having trouble getting Zeroshell to “feed” VLAN tagged packets to my Linksys managed switch. At least it seems that way. Here’s the setup:

    Zeroshell in a VM on ESX

      2 Physical NIC’s (Intel Pro 1000 Dual/copper)
      one uplink/outside ETH01, one IP
      one VLAN’s/inside ETH00, three IP’s, (VLAN 10), (VLAN 20)
      DHCP on VLAN 10 and VLAN 20
      NAT enabled on ETH01

    As far as I know, the SRW248 switch is set correctly

      zeroshell to switch set to trunking, accept tagged packets on VLAN 10 & 20
      Client ports set to accept untagged packets on VLAN’s 10 or 20

    Is there any way to test and see if it is Zeroshell or Linksys that is not VLAN’ing?



    You should have another device that is VLAN aware to connect directly to Zeroshell. For example a Linux computer. You have to use the vconfig command to enable the trunk on the interface. In alternative you could directly connect two Zeroshell to check if VLAN work fine. I often use VLAN trunking without any issue.



    The problem definately occurrs between the VM (Zeroshell) and the host (ESX 3.5). I was able to test my switch with a borrowed 802.1q router and vlans definately work.

    While I did discover that on ESX Server in order to pass VLAN’s along to the guest OS, one must specify a vlan ID of 4095 on the Port Group containing the VM, http://www.vmware.com/pdf/esx3_vlan_wp.pdf that has been done ans still no luck.

    One thing I noticed is that the two Broadcom NIC’s on my ESX are running a driver called tg3 and the two Intel NIC’s are running an e1000 driver, but the VM (Zeroshell) itself sees: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 10) . Could the virtual NIC driver be causing Zeroshell not to pass along tagged packets?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.