Zeroshell 3.9.3A on Raspberry pi 3B+

Forums Network Management ZeroShell Zeroshell 3.9.3A on Raspberry pi 3B+

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #65799

    I tried to install version 3.9.3A on raspberry pi 3B + without success.
    After flashing on microsd the operating system does not start (I tried with version 3.9.1A and it works).
    Anyone help me?

    Jean-christophe L.

    Hi M,
    the file “cmdline.txt” inside the FAT partition of the raspberry 3.9.3A image are corrupted.
    To solve the problem, you have to create a new file named “cmdline2.txt” at the same level of the corrupted “cmdline.txt”. Copy this text inside the “cmdline2.txt” :
    root=HD=ZS-A7E25B3C_3.9.3A_1 rootwait panic=10 loglevel=0 elevator=noop dwc_otg.lpm_enable=0 quiet
    Rename “cmdline.txt” to “cmdline3.txt” and finally rename “cmdline2.txt” to “cmdline.txt”.

    The raspberry should start normally with this new “cmdline.txt”.


    Daniele Testa

    Something else must also be wrong, because it does not work for me. I could see that the cmdline.txt was corrupt with something that looked like a binary file. I replaced it with the contents that you provided. I have a Raspberry Pi 3+ and it gets stuck with the large “rainbow box” at boot.

    Further, I can say that all works fine with Rasbian on the same device and same SD-card, so I know that all hardware is OK.

    As a side-note, I find it VERY strange that the official image does not get fixed if the corrupted cmdline.txt is a known issue??

    UPDATE: I got it working by replacing all .dtd and .elf files with working versions from Rasbian. It’s pretty obvious that this official release needs to be fixed!

    • This reply was modified 1 year, 11 months ago by Daniele Testa.
    Daniele Testa

    I spoke too soon. USB is not working at all, so no keyboard or USB Ethernet adapters.
    Also seems like it does not have correct firmware for the built-in WiFi adapter. I believe it’s the same as on the Zero W model.

    Btw, I have a Raspberry Pi 3A+, not 3B+ like the original poster.

    Jean-christophe L.

    My config is a Raspberry 3B so the native firmware of the 3.9.3A is the right one :-).

    The FAT partition (/dev/mmcblk0p1) of the 3.9.3A image is corrupt so a linux fsck need to be done from the zeroshell prompt :
    fsck /dev/mmcblk0p1 -V

    A chkdsk with a Windows workstation should also works but i didn’t test this.

    Magnus Hallback

    Is Zeroshell maintained by someone anymore?
    It seems strange that a corrupted image is not fixed by the maintainer since it was released?


    Hi All,
    Fixed by copying the “cmdline.txt” file from version 3.9.0A to 3.9.3A (the file is corrupt in version 3.9.3A).


    hi all.

    personnally the file wasn’t corrupted and i could install and bootup the distro from img directly.

    testing it now but it seems promising. good job for the dev.



    Ha the corrupt file issue happened one time… So it seems it’s a bit random or dependent on the way used to flash SD card? I’m playing between windows and linux so i can’t remember what’s i’ve used 1st time…

    Rebuild the file fix the problem.

    kunal patil

    Apart from our in-house products, we have all the leading kitchen accessory brands suchas Hettich, Evershine, Blum Kitchen, Kitchen Grass, etc.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.