Zeroshell not booting on Hyper-V

Forums Network Management ZeroShell Zeroshell not booting on Hyper-V

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #65427


    I already experienced this in the past, and managed to install an old version (3.4.x).

    Now I decided to give it a new try, and installed Zeroshell 3.9.3 on a Hyper-V VM, Windows 2012 R2 host, HP DL380G6 physical hardware, worked like a charm.

    Then wanted to install it on another host, also Windows 2012 R2, but physical HP DL380G5, got the same issue as in the past : stuck when displaying “Booting the kernel.”

    Had to revert to version 3.8.2 to have it booting, but now on installation it gets stuck on “Writing MBR …”. Retried and got a lot of error messages starting with “unable to handle kernel NULL pointer …”

    Same for versions 3.8.0 and 3.7.1.

    I tried copying the vhdx file containing installed version 3.9.3 on the second host, boot it in a VM, stays stuck on “Booting the kernel.”. Don’t know what it does, but CPU usage is 12% in Hyper-V for this VM (8 cores assigned). Same issue if I assign only 1 core.

    Only version I can successfully boot and install is 3.4.0.

    Does anyone know why it is so complicated on Hyper-V ?

    Fulvio, I would be happy to help if you have any instructions to send you debug details.

    David Mott

    This is a long shot but make sure you use Gen 1 and boot with BIOS instead of UEFI. I have it running on ESXi and both public and private NICs are in PCI pass-through mode so the client has exclusive access to them. This is important in my case for isolation for me since I don’t want the possibility of any other VMs acquiring or using a public address from the ISP.


    Hi David,

    Didn’t see your answer before.

    Yes it is Gen1, and there is no UEFI (UEFI only available on Gen2).

    On my side I don’t want exclusive access to NICs, I may want another VM to be on the public side, but I certainly need to share the private NIC with other VMs.

    Furthermore, this works like a charm on the DL380G6.

    Just tried v3.9.4 on the DL380G5, still not booting. I’m suspecting a bug with Lan-to-Lan VPN in TCP mode on the v3.4.0 so I wanted to give a try with a newer release, with no luck on the boot part.

    Such annoying …

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.