zeroshell on esxi 4.0, please help

Forums Network Management ZeroShell zeroshell on esxi 4.0, please help

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #41999


    i have tried to install zeroshell on to my esxi 4 server with no succes…
    i even tried to convert the vmware machine to ova but it wont boot.

    please help or upload a esx appliance of zeroshell



    Forget about the pre-configured VM’s, they are mostly for VMware Server. Use the .ISO image and make sure you upload the ISO to the datastore using the vSphere client.

    Edit the VM settings for the CD/DVD and make sure to select “Datastore ISO file” and “Connect at power on.”

    Last step is to check the VM BIOS by pressing F2 when you see the VMware Post screen (must be quick here) and make sure the boot order specifies to boot from CD first.

    From here on out, it will work just like Zeroshell on hardware!

    BTW in order to use VLAN’s inside a VM, you must select VLAN ID 4095 (VGT) on the Port Group associated.

    -J [/list]


    ok uploaded the iso file to my datastore and booting from the iso now.
    works great this way ! ๐Ÿ˜€
    and i will be easy to upgrate a newer version, just boot from new iso…

    thx for the help ๐Ÿ™‚


    I have had great success with installing ZeroShell in ESXi4 by installing it to an IDE drive instead of Sata in VMWare Machine Setup.

    First make 2GB IDE disk in the VM setup & 512MB Ram
    I then boot the VM Guest off Ubuntu-Desktop-32.iso (Cause I already have it in my datacenters ISO folder, I bet you can use another distro)
    Download the ZeroShell IDE Sata USB img.gz
    Open a shell – Apps / Acc / Terminal
    sudo bash
    gunzip -c /home/ubuntu/Downloads/Zero*.img.gz>/dev/sda
    (NOTE: sda not sda1)
    shutdown, reduce RAM & remove the iso cd-rom from VM.

    All Done



    @unsichtbare wrote:

    BTW in order to use VLAN’s inside a VM, you must select VLAN ID 4095 (VGT) on the Port Group associated.

    Actually, to be technically correct, VLAN ID 4095 will span ALL VLANs on an attached and correctly configured switch, which is probably not what most people want. (Further, this is pre-vSphere behavior, now can span inclusively and exclusively without relying on VLAN 4095, as well as use PVLANs with an Enterprise Plus license.)

    In fact, to use a VLAN inside a VM, you simply specify the appropriate VLAN tag as the VLAN ID on the associated PortGroup, though your switch will have to fully support 802.1q and the physical switch port where ESXi is attached will need to be trunked for bidirectional tagging and trunking.



    thx bryanpop !

    i will try that, now running from the iso and works fine.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.