Zeroshell Stops under load

Forums Network Management ZeroShell Zeroshell Stops under load

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #40917


    I’ve been using Zeroshell from quite some time now its been working superbly until very recently, I’ve configured it in Bridge mode and using the L7 Filter with about 35 rules to shape the traffic. Whats happening is when theres peak traffic the system just freezes until I remove the bridge interface and after about a couple of minutes comes back up just fine.

    I’ve used Beta7 and Beta8 but face the same problem its shaping 12MB of WAN traffic and connected between my router and Switch.

    The system config is as follows;
    Intel 915Chipset Motherboad
    Intel 2.8Ghz D CPU
    1GB Ram
    Intel and 3 Com lan cards.

    Ive tried booting the system with the ACPI option but still it doesnt seem to make a difference the only difference I can think of is that the traffic has gone up by maybe 4 Megs very recently.

    Please can you help me understand whats making this happening, having a hard time without it shaping my network.

    Best Regards,




    Please can someone help me tweak it so it can handle more traffic more effectively.




    Can you post the load average?

    In the console


    will show it

    Whats your CPU usage?


    will show it

    It is better if you decrease the filter rules?
    Can you try Memtest? ( )


    Hi raymond,

    The cpu usage on top doesn’t ever exceed 3%. When the box stops responding and I remove the bridge cable it comes back to life in a couple of minutes like nothing ever happened.

    I have now tried it on another machine which is a Intel Server motherboard with a 2.8D CPU and 2 Gigs of ram but its still behaving the same and very similar stats in top.

    I’d like to think if it was lacking sheer proc power then it would look at using more then just 3% of the cpu.

    Is there something else I can do to make more effective?

    Best Regards,



    I have a very similar situation and while load on the cpu load always remain very low, when a lot of traffic comes through zeroshell stops processing for a few seconds. Sometimes minutes. Sometimes it does not come back to life and a reboot is required.

    Had to take it out of the loop eventually as it’s not reliable. Happens a lot on beta 7 but a few times on beta 8 though less.


    We’re pushing a ton of traffic (metro ethernet @100Mb), and using b7 and b8 without problems. Heck, I think the only problem I had at first with b7 was the hardware. It happened the network cards I took from a recycle pile were both _very_ faulty.

    For the pilot, I used a Dell 1850 with Intel 1gb cards, and currently have Dell 1950’s with b8 on them. We’re shaping I/O 90Mb/55Mb peak, and about I/O 35Mb/17Mb weekly average.

    We haven’t had any problems save for hardware NIC’s. Though b8, I’ve had a weird web site deal; the administrative user and session just goes away. I get all of the web panes before logon that “take too long to respond”.

    So, I’m thinking of switching back to b7.


Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.