zscp segfault at fffffff4 and users unhappy

Forums Network Management Signal a BUG zscp segfault at fffffff4 and users unhappy

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #42651

    I have a lot of errors and the users soffer slow/repeated authentications. The user should close the browser and reopen it to obtain again the authentication page. πŸ™ πŸ™ (see the log below)

    This happens usually when there are more than 10-20 clients (but it’s random), and with the beta13 release, but also in beta12.

    Rebooting the appliance resolves for a while the problem. πŸ™
    My client network (captured LAN) is “slow”, it means that I have many residences with radio links, or vdsl links (network extender), is possible that the negotiation for the authentication expect instead a fast answer from client?

    The “hardware” is a virtualized machine with vmware ESXi, but I did not use the true vmware release because the virtual disk is ide-based, ESXi instead wants scsi-based virtual disk and I was not able to import it (I am not skilled in vmware world :-(). So I create a virtual machine booting fron the CD (iso). Are there any differences the kernels between the two versions?

    07:18:13 	zscp[4808]: segfault at fffffff4 ip b7fe4019 sp bf839f4c error 4 in libstdc++.so.5.0.5[b7f64000+9e000]
    07:42:05 zscp[18863]: segfault at fffffff4 ip b8013019 sp bfb693bc error 4 in libstdc++.so.5.0.5[b7f93000+9e000]
    07:42:16 zscp[19107]: segfault at fffffff4 ip b7f26019 sp bfc7c4dc error 4 in libstdc++.so.5.0.5[b7ea6000+9e000]
    07:43:07 zscp[20267]: segfault at fffffff4 ip b7f88019 sp bfadeb1c error 4 in libstdc++.so.5.0.5[b7f08000+9e000]
    07:43:28 zscp[20703]: segfault at fffffff4 ip b8029019 sp bfb7f3bc error 4 in libstdc++.so.5.0.5[b7fa9000+9e000]
    07:53:34 zscp[32757]: segfault at fffffff4 ip b7ec3019 sp bf81906c error 4 in libstdc++.so.5.0.5[b7e43000+9e000]
    07:58:25 zscp[5745]: segfault at fffffff4 ip b7f16019 sp bff6e7ec error 4 in libstdc++.so.5.0.5[b7e96000+9e000]
    08:37:19 zscp[22172]: segfault at fffffff4 ip b7ee1019 sp bff3978c error 4 in libstdc++.so.5.0.5[b7e61000+9e000]
    08:37:35 zscp[22247]: segfault at fffffff4 ip b7f67019 sp bfebd70c error 4 in libstdc++.so.5.0.5[b7ee7000+9e000]

    Still the same problem.
    For now I inserted a cron that reboots the appliance every night, but at a random time in the day, suddenly it happens again πŸ˜₯ :

    01:01:42 	 EXT3-fs: mounted filesystem with ordered data mode.
    01:01:42 Adding 131064k swap on /DB/swap-file. Priority:-1 extents:34 across:137352k
    01:01:42 warning: `named' uses 32-bit capabilities (legacy support in use)
    01:01:42 nf_conntrack version 0.5.0 (65536 buckets, 524288 max)
    01:01:45 ip_tables: (C) 2000-2006 Netfilter Core Team
    01:01:47 Bridge firewalling registered
    01:01:47 DEFAULTBR: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
    01:01:47 tun: Universal TUN/TAP device driver, 1.6
    01:01:47 tun: (C) 1999-2004 Max Krasnyansky
    01:01:47 wlan: 0.9.4
    01:01:47 ath_hal: module license 'Proprietary' taints kernel.
    01:01:47 ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    01:01:47 ath_rate_sample: 1.2 (0.9.4)
    01:01:47 ath_pci: 0.9.4
    01:01:47 ath_pci: driver unloaded
    01:01:47 ath_rate_sample: unloaded
    01:01:48 ath_hal: driver unloaded
    01:01:48 wlan: driver unloaded
    01:01:48 ETH00: link up
    01:01:48 ETH01: link up
    13:23:57 zscp[535]: segfault at fffffff4 ip b802e019 sp bfd86d9c error 4 in libstdc++.so.5.0.5[b7fae000+9e000]
    13:24:13 zscp[2003]: segfault at fffffff4 ip b7eaa019 sp bf80085c error 4 in libstdc++.so.5.0.5[b7e2a000+9e000]
    13:25:27 zscp[5760]: segfault at fffffff4 ip b802c019 sp bf88486c error 4 in libstdc++.so.5.0.5[b7fac000+9e000]
    13:25:42 zscp[7056]: segfault at fffffff4 ip b7fce019 sp bfa2420c error 4 in libstdc++.so.5.0.5[b7f4e000+9e000]
    13:25:51 zscp[7371]: segfault at fffffff4 ip b7f89019 sp bfddf5cc error 4 in libstdc++.so.5.0.5[b7f09000+9e000]
    13:26:05 zscp[8162]: segfault at fffffff4 ip b7f5a019 sp bf8b210c error 4 in libstdc++.so.5.0.5[b7eda000+9e000]
    13:26:20 zscp[9786]: segfault at fffffff4 ip b7f3b019 sp bf9931ec error 4 in libstdc++.so.5.0.5[b7ebb000+9e000]
    13:28:13 zscp[15600]: segfault at fffffff4 ip b804c019 sp bffa27ec error 4 in libstdc++.so.5.0.5[b7fcc000+9e000]
    13:32:54 zscp[31163]: segfault at fffffff4 ip b80a5019 sp bfbfb44c error 4 in libstdc++.so.5.0.5[b8025000+9e000]
    13:34:06 zscp[2009]: segfault at fffffff4 ip b7fa8019 sp bfafeb4c error 4 in libstdc++.so.5.0.5[b7f28000+9e000]
    13:34:32 zscp[3118]: segfault at fffffff4 ip b7faf019 sp bfb07b5c error 4 in libstdc++.so.5.0.5[b7f2f000+9e000]
    13:35:38 zscp[6445]: segfault at fffffff4 ip b7ffa019 sp bff51ecc error 4 in libstdc++.so.5.0.5[b7f7a000+9e000]
    13:36:03 zscp[7901]: segfault at fffffff4 ip b8022019 sp bfa7aa4c error 4 in libstdc++.so.5.0.5[b7fa2000+9e000]
    13:36:24 zscp[8988]: segfault at fffffff4 ip b808b019 sp bfbe33ac error 4 in libstdc++.so.5.0.5[b800b000+9e000]
    13:51:51 zscp[13415]: segfault at fffffff4 ip b7fdb019 sp bfd3157c error 4 in libstdc++.so.5.0.5[b7f5b000+9e000]
    13:52:47 zscp[15340]: segfault at fffffff4 ip b7eca019 sp bf92297c error 4 in libstdc++.so.5.0.5[b7e4a000+9e000]
    13:53:17 zscp[17254]: segfault at fffffff4 ip b803e019 sp bfc94cec error 4 in libstdc++.so.5.0.5[b7fbe000+9e000]
    13:54:21 zscp[20982]: segfault at fffffff4 ip b7ea8019 sp bfbfec4c error 4 in libstdc++.so.5.0.5[b7e28000+9e000]
    13:55:16 zscp[23492]: segfault at fffffff4 ip b7f95019 sp bfced53c error 4 in libstdc++.so.5.0.5[b7f15000+9e000]
    13:55:27 zscp[23707]: segfault at fffffff4 ip b7f12019 sp bfa6aaac error 4 in libstdc++.so.5.0.5[b7e92000+9e000]
    13:55:31 zscp[23920]: segfault at fffffff4 ip b7ef8019 sp bfc4e49c error 4 in libstdc++.so.5.0.5[b7e78000+9e000]
    14:06:27 zscp[23087]: segfault at fffffff4 ip b7eb9019 sp bf81186c error 4 in libstdc++.so.5.0.5[b7e39000+9e000]
    14:10:24 zscp[4100]: segfault at fffffff4 ip b7fe2019 sp bfa3828c error 4 in libstdc++.so.5.0.5[b7f62000+9e000]
    14:10:48 zscp[6001]: segfault at fffffff4 ip b7f60019 sp bffb880c error 4 in libstdc++.so.5.0.5[b7ee0000+9e000]
    14:13:24 zscp[16396]: segfault at fffffff4 ip b7f28019 sp bfd80dcc error 4 in libstdc++.so.5.0.5[b7ea8000+9e000]
    14:17:41 zscp[3615]: segfault at fffffff4 ip b8018019 sp bfc6e4bc error 4 in libstdc++.so.5.0.5[b7f98000+9e000]
    14:18:24 zscp[6644]: segfault at fffffff4 ip b7f8d019 sp bfae532c error 4 in libstdc++.so.5.0.5[b7f0d000+9e000]
    14:19:41 zscp[12555]: segfault at fffffff4 ip b7ecd019 sp bfc233cc error 4 in libstdc++.so.5.0.5[b7e4d000+9e000]
    14:24:50 zscp[32313]: segfault at fffffff4 ip b7ff9019 sp bfe51e2c error 4 in libstdc++.so.5.0.5[b7f79000+9e000]
    14:25:04 zscp[727]: segfault at fffffff4 ip b7f0e019 sp bfa64a3c error 4 in libstdc++.so.5.0.5[b7e8e000+9e000]
    14:26:09 zscp[5496]: segfault at fffffff4 ip b806c019 sp bfcc4c6c error 4 in libstdc++.so.5.0.5[b7fec000+9e000]
    14:28:58 zscp[15785]: segfault at fffffff4 ip b7fa8019 sp bfefe6ac error 4 in libstdc++.so.5.0.5[b7f28000+9e000]
    14:29:17 zscp[17263]: segfault at fffffff4 ip b7ffd019 sp bfe53ddc error 4 in libstdc++.so.5.0.5[b7f7d000+9e000]
    14:29:21 zscp[17886]: segfault at fffffff4 ip b7eb3019 sp bfb0935c error 4 in libstdc++.so.5.0.5[b7e33000+9e000]
    14:29:34 zscp[18570]: segfault at fffffff4 ip b8018019 sp bff70fbc error 4 in libstdc++.so.5.0.5[b7f98000+9e000]
    14:29:38 zscp[18857]: segfault at fffffff4 ip b8099019 sp bf9ef04c error 4 in libstdc++.so.5.0.5[b8019000+9e000]
    14:30:14 zscp[21870]: segfault at fffffff4 ip b7eb7019 sp bf90f15c error 4 in libstdc++.so.5.0.5[b7e37000+9e000]
    14:30:18 zscp[22025]: segfault at fffffff4 ip b7f9a019 sp bfef0cdc error 4 in libstdc++.so.5.0.5[b7f1a000+9e000]
    14:30:43 zscp[24037]: segfault at fffffff4 ip b7fac019 sp bfe02dec error 4 in libstdc++.so.5.0.5[b7f2c000+9e000]
    14:30:54 zscp[24637]: segfault at fffffff4 ip b7f52019 sp bfdaad8c error 4 in libstdc++.so.5.0.5[b7ed2000+9e000]
    14:31:36 zscp[27968]: segfault at fffffff4 ip b7ebc019 sp bfa12a6c error 4 in libstdc++.so.5.0.5[b7e3c000+9e000]
    14:32:04 zscp[30349]: segfault at fffffff4 ip b808c019 sp bfce4cbc error 4 in libstdc++.so.5.0.5[b800c000+9e000]
    14:32:41 zscp[32666]: segfault at fffffff4 ip b8093019 sp bffe983c error 4 in libstdc++.so.5.0.5[b8013000+9e000]
    14:33:16 zscp[2046]: segfault at fffffff4 ip b8061019 sp bfdb95dc error 4 in libstdc++.so.5.0.5[b7fe1000+9e000]
    14:33:28 zscp[2736]: segfault at fffffff4 ip b7efc019 sp bff54f2c error 4 in libstdc++.so.5.0.5[b7e7c000+9e000]
    14:33:32 zscp[3047]: segfault at fffffff4 ip b809e019 sp bf8f40cc error 4 in libstdc++.so.5.0.5[b801e000+9e000]
    14:33:42 zscp[3645]: segfault at fffffff4 ip b7fcc019 sp bff2476c error 4 in libstdc++.so.5.0.5[b7f4c000+9e000]
    14:33:56 zscp[5053]: segfault at fffffff4 ip b7eed019 sp bfb4338c error 4 in libstdc++.so.5.0.5[b7e6d000+9e000]
    14:34:24 zscp[6484]: segfault at fffffff4 ip b7f0d019 sp bfa63abc error 4 in libstdc++.so.5.0.5[b7e8d000+9e000]
    14:34:43 zscp[8226]: segfault at fffffff4 ip b7f39019 sp bfb8f3dc error 4 in libstdc++.so.5.0.5[b7eb9000+9e000]
    14:40:33 zscp[28100]: segfault at fffffff4 ip b7f0b019 sp bfc614ac error 4 in libstdc++.so.5.0.5[b7e8b000+9e000]
    14:44:42 zscp[9796]: segfault at fffffff4 ip b807e019 sp bfcd4c8c error 4 in libstdc++.so.5.0.5[b7ffe000+9e000]
    14:45:06 zscp[11934]: segfault at fffffff4 ip b7f88019 sp bfade29c error 4 in libstdc++.so.5.0.5[b7f08000+9e000]
    14:45:34 zscp[13238]: segfault at fffffff4 ip b7ffd019 sp bfe5560c error 4 in libstdc++.so.5.0.5[b7f7d000+9e000]
    14:45:51 zscp[14169]: segfault at fffffff4 ip b8046019 sp bfb9cb9c error 4 in libstdc++.so.5.0.5[b7fc6000+9e000]
    14:47:00 zscp[18695]: segfault at fffffff4 ip b7ec6019 sp bfb1cb5c error 4 in libstdc++.so.5.0.5[b7e46000+9e000]
    14:47:38 zscp[21347]: segfault at fffffff4 ip b7f45019 sp bf99b1dc error 4 in libstdc++.so.5.0.5[b7ec5000+9e000]
    14:48:13 zscp[24404]: segfault at fffffff4 ip b8041019 sp bfd9758c error 4 in libstdc++.so.5.0.5[b7fc1000+9e000]
    14:48:22 zscp[24866]: segfault at fffffff4 ip b7f39019 sp bfc9146c error 4 in libstdc++.so.5.0.5[b7eb9000+9e000]
    14:48:32 zscp[25615]: segfault at fffffff4 ip b7ee3019 sp bf83b82c error 4 in libstdc++.so.5.0.5[b7e63000+9e000]
    14:48:57 zscp[27178]: segfault at fffffff4 ip b7fe3019 sp bfe3940c error 4 in libstdc++.so.5.0.5[b7f63000+9e000]
    14:49:14 zscp[28319]: segfault at fffffff4 ip b7ffd019 sp bfe53e2c error 4 in libstdc++.so.5.0.5[b7f7d000+9e000]
    14:50:22 zscp[770]: segfault at fffffff4 ip b802b019 sp bfd83d5c error 4 in libstdc++.so.5.0.5[b7fab000+9e000]
    14:50:47 zscp[2492]: segfault at fffffff4 ip b7f04019 sp bfd5cd2c error 4 in libstdc++.so.5.0.5[b7e84000+9e000]

    Any Suggestion?


    I changed the hardware but the problem remains.
    For few days it worked, but then it starts again.

    From the graphics you can think that there is memory allocation problem, in fact I putted a crontab that reboot the appliance every night, the memory occupation is low just after the reboot and is increasing always untile the next reboot.

    I still wait for a solution..


    Are you using the transparent proxy?
    You should try creating a cron job with the following command:

    service cp restart

    That restarts the captive portal daemons (Apache).



    Thank you!
    previously I made the same that did “reboot”, but has happened the terrible “LDAP RECOVERY DB” error at startup, so I disabled it.

    If this restarts only the service is better.
    πŸ˜€ πŸ˜€


    @fulvio wrote:

    You should try creating a cron job with the following command:

    service cp restart

    That restarts the captive portal daemons (Apache).


    It’s a bug into a bug πŸ˜€
    I discover that if I “Test” it (with the button), it worked.
    But the crontab does not inherit the $PATH, so I replaced with absolute path:

    # Bash script: RestartCP-Cron
    /sbin/service cp restart

    Now is ok, I saw it in the logs.


    The Beta14 release updates the same bug:

    00:04:40 	device ETH01 entered promiscuous mode
    00:04:41 device ETH01 left promiscuous mode
    00:04:45 device ETH01 entered promiscuous mode
    00:04:50 device ETH01 left promiscuous mode
    10:35:59 zscp[25401]: segfault at 1099f9b3 ip b7ffb3f0 sp bf969e90 error 4 in libstdc++.so.6.0.14[b7f72000+ce000]
    10:37:07 zscp[31034]: segfault at 121f49b3 ip b7fbb3f0 sp bf92be20 error 4 in libstdc++.so.6.0.14[b7f32000+ce000]
    10:37:17 zscp[31764]: segfault at 111ca9b3 ip b7f933f0 sp bf804500 error 4 in libstdc++.so.6.0.14[b7f0a000+ce000]
    10:37:29 zscp[1050]: segfault at 118839b3 ip b80003f0 sp bfa6f770 error 4 in libstdc++.so.6.0.14[b7f77000+ce000]
    10:37:37 zscp[2689]: segfault at 10f749b3 ip b7f2f3f0 sp bfda02a0 error 4 in libstdc++.so.6.0.14[b7ea6000+ce000]
    10:41:15 zscp[24739]: segfault at 105079b3 ip b7f5d3f0 sp bfdcca50 error 4 in libstdc++.so.6.0.14[b7ed4000+ce000]
    10:42:05 zscp[30466]: segfault at 11d299b3 ip b7ec73f0 sp bff35d60 error 4 in libstdc++.so.6.0.14[b7e3e000+ce000]
    10:45:14 zscp[18475]: segfault at 11daa9b3 ip b7f4c3f0 sp bfebd340 error 4 in libstdc++.so.6.0.14[b7ec3000+ce000]
    10:46:05 zscp[23227]: segfault at 10a169b3 ip b7f2b3f0 sp bfb9c820 error 4 in libstdc++.so.6.0.14[b7ea2000+ce000]

    Now, there is “libstdc++.so.6.0.14” instead of “libstdc++.so.5.0.5“. πŸ™

    After upgrading I leaved the script that, every hour, do a

    /sbin/service cp restart

    and this “solves” the problem.


    New version (b16), new version of the bug:

    21:13:40 	zscp[17558]: segfault at 0 ip b7cfe5e3 sp bfc07aac error 4 in libc-2.8.so[b7c8d000+139000]
    21:21:15 zscp[26673]: segfault at 0 ip b7e125e3 sp bfd1dc2c error 4 in libc-2.8.so[b7da1000+139000]
    21:34:31 zscp[24540]: segfault at 0 ip b7d575e3 sp bf861f7c error 4 in libc-2.8.so[b7ce6000+139000]
    21:36:27 zscp[23095]: segfault at 0 ip b7da05e3 sp bffa972c error 4 in libc-2.8.so[b7d2f000+139000]
    21:36:28 zscp[23658]: segfault at 0 ip b7d715e3 sp bfd7a4fc error 4 in libc-2.8.so[b7d00000+139000]
    21:36:29 zscp[24150]: segfault at 0 ip b7e365e3 sp bfd3f4cc error 4 in libc-2.8.so[b7dc5000+139000]
    21:36:31 zscp[24727]: segfault at 0 ip b7e6e5e3 sp bf9770fc error 4 in libc-2.8.so[b7dfd000+139000]
    21:37:06 zscp[1461]: segfault at 0 ip b7dc25e3 sp bfacb20c error 4 in libc-2.8.so[b7d51000+139000]
    21:38:40 zscp[23452]: segfault at 0 ip b7e625e3 sp bfc6d3ec error 4 in libc-2.8.so[b7df1000+139000]
    21:45:49 zscp[30073]: segfault at 0 ip b7d175e3 sp bf92207c error 4 in libc-2.8.so[b7ca6000+139000]
    21:58:16 zscp[12195]: segfault at 0 ip b7e825e3 sp bfa8ba2c error 4 in libc-2.8.so[b7e11000+139000]
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.