jbo5112

Forum Replies Created

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • in reply to: kerberos problems #50942
    jbo5112
    Member

    It appears the kerberos server has stability problems. I ran into this again and restarting the service fixed the issue.

    in reply to: A Little DNS / Domain Help? #50717
    jbo5112
    Member

    I don’t know if you’ve figured this out by now, but it appears that you don’t have an ‘A’ record for onegrange.net. Select it from the list of entries, then click to add a new resource command (next to the left and right arrows). I don’t know if this will fix anything, but you also need add an ‘A’ entry for zeroshell. I’m not sure if everything is dependent on being able to lookup the ip address of the NS.

    in reply to: kerberos problems #50941
    jbo5112
    Member

    Ubuntu has a several kerberos zones preconfigured for MIT and Stanford. I commented them out, even though no instructions ever mention this.

    Ubuntu Server 10.04 wasn’t running software to synchronize the time, which had drifted nearly 58 seconds, so I set that up. I hadn’t gotten an error related to this, which I’ve seen other posts mention, but it would eventually be a problem.

    I neglected to configure reverse DNS in zeroshell, so I set that up for no real reason other than professionalism. Now it works. I’m guessing it was the DNS, but after all the fruitless labor, I don’t really care.

    in reply to: HowTo: vmware-tools in ZeroShell #50100
    jbo5112
    Member

    The modules cannot be compiled on zeroshell. They can be compiled on another system and copied onto the zeroshell system. On the current release of zeroshell, this requires a system with GCC 4.3.X and kernel 2.6.25.20 configured and installed. The configuration is store in /proc/config.gz on zeroshell and it needs to be gunzipped and placed in /usr/src/linux/.config on the machine with GCC.

    I think vmware-tools might be specific to the version of VMware that you’re running. With the proper version of the kernel installed, including sources, and a back up copy of /lib/modules/2.6.25.20/modules.* (.bin files not required) you can now install vmware-tools on the machine with GCC to build the kernel modules. The modules will end up in “/lib/modules/2.6.25.20/misc/”. To find the updates to the backed up files, you’ll have to compare sorted versions of the files, so you can add the new entries to the same files on zeroshell. When I installed the same kernel on Ubuntu 9.04 server, my files in /lib/modules/2.6.25.20/modules.* weren’t the same as the files on zeroshell. It might have helped if I had downloaded the kernel from zeroshell instead of a kernel.org mirror. However, the command insmod appeared to work without changing the modules.* files on zeroshell, but I did not check to see if the modules actually worked.

    I’m currently running Zeroshell on ESXi with a working vmxnet3 NIC. I don’t know how to check if anything else works, except all the modules load and vmmemctl and vmtoolsd show up in my process list. I did run into a problem with vmware creating .old.? files for me that BROKE THEIR PROGRAMS. Delete these if you ever find them. My vmware init doesn’t appear to load the modules automatically, but I have all the additional entries in my modules.* files for your modding pleasure.

    file: modules.alias

    alias pci:v00001022d00002000sv*sd*bc*sc*i* vmxnet
    alias pci:v000015ADd00000720sv*sd*bc*sc*i* vmxnet
    alias pci:v000015ADd00000740sv*sd*bc*sc*i* vmci
    alias pci:v000015ADd000007B0sv*sd*bc*sc*i* vmxnet3
    alias pci:v000015ADd000007C0sv*sd*bc*sc*i* pvscsi

    file: modules.dep

    /lib/modules/2.6.25.20/misc/pvscsi.ko:
    /lib/modules/2.6.25.20/misc/vmblock.ko:
    /lib/modules/2.6.25.20/misc/vmci.ko:
    /lib/modules/2.6.25.20/misc/vmhgfs.ko:
    /lib/modules/2.6.25.20/misc/vmmemctl.ko:
    /lib/modules/2.6.25.20/misc/vmxnet.ko:
    /lib/modules/2.6.25.20/misc/vmxnet3.ko:
    /lib/modules/2.6.25.20/misc/vsock.ko: /lib/modules/2.6.25.20/misc/vmci.ko

    file: modules.pcimap

    pvscsi               0x000015ad 0x000007c0 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0
    vmci 0x000015ad 0x00000740 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0
    vmxnet 0x00001022 0x00002000 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0
    vmxnet 0x000015ad 0x00000720 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0
    vmxnet3 0x000015ad 0x000007b0 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0

    file: modules.symbols

    alias symbol:VMCIContext_GetPrivFlags vmci
    alias symbol:VMCIDatagram_CreateHnd vmci
    alias symbol:VMCIDatagram_CreateHndPriv vmci
    alias symbol:VMCIDatagram_DestroyHnd vmci
    alias symbol:VMCIDatagram_Send vmci
    alias symbol:VMCIDs_Lookup vmci
    alias symbol:VMCIEvent_Subscribe vmci
    alias symbol:VMCIEvent_Unsubscribe vmci
    alias symbol:VMCIMemcpyFromQueue vmci
    alias symbol:VMCIMemcpyFromQueueV vmci
    alias symbol:VMCIMemcpyToQueue vmci
    alias symbol:VMCIMemcpyToQueueV vmci
    alias symbol:VMCIQueuePair_Alloc vmci
    alias symbol:VMCIQueuePair_AllocPriv vmci
    alias symbol:VMCIQueuePair_Detach vmci
    alias symbol:VMCISock_GetAFValue vsock
    alias symbol:VMCISock_GetLocalCID vsock
    alias symbol:VMCISock_KernelDeregister vsock
    alias symbol:VMCISock_KernelRegister vsock
    alias symbol:VMCI_DeviceGet vmci
    alias symbol:VMCI_DeviceRelease vmci
    alias symbol:VMCI_GetContextID vmci
    alias symbol:VMCI_Version vmci

    I also moved my installation to of everything for vmware-tools /DB instead of /Database so it is installed on zeroshell instead of just the current Database. However, the boot script needs to be modified for each database. Also my vmware tools install creates the file /etc/udev/rules.d/99-vmware-scsi-udev.rules and the symbolic a link /etc/pam.d/vmtoolsd, which I backed up and have my script restore.

    in reply to: HowTo: vmware-tools in ZeroShell #50098
    jbo5112
    Member

    I checked the files /lib/modules/2.6.25.20/modules.* aren’t the same between zeroshell and the linux system where I installed that kernel with the same configuration. What’s worse is that when vmware tools is installed, it scrambles the order of the lines in some of the files. If you want the modules properly installed, you’ll have to compare sorted versions of the files from before and after vmware tools is installed. If someone is interested, I can provide details of what changes I made for zeroshell 1.0.beta13 and the vmware tools in ESXi 4.1. All the modules install without these changes, but I’ve only tried running a vmxnet3 NIC with the changes in place.

    I previously left something out for for my vmxnet3 under ESXi. The boot script needs to run “/etc/init.d/netconfig restart” to initialize the device, and I’ve updated the script in my previous post.

    in reply to: HowTo: vmware-tools in ZeroShell #50097
    jbo5112
    Member

    Thank you very much for this help. Adding the vmware modules isn’t very difficult if you know how to compile a kernel (you don’t even have to configure it). You’ll just have to find a full Linux distribution with a compatible GCC. I’m running 1.0.beta13, which uses GCC 4.3.2 and kernel 2.6.25.20. It requires another i386 (32-bit x86) linux distribution with GCC 4.3.x. The last number indicates a bug fix and is almost always binary compatible. Once you have a distribution with a compatible GCC, you compile/install the same kernel that zeroshell uses, reboot, install vmware-tools, and copy the modules to zeroshell. I apologize if this guide is a little incoherent, it’s getting quite late.

    Creating Build Environment
    I created a virtual machine with a minimal Ubuntu 9.04 server with the packages GCC and make installed and as many virtual CPU’s as I have real CPU cores. Next I downloaded the specific zeroshell kernel source from kernel.org (2.6.25.20) to the folder /usr/src on the Ubuntu server, by finding the specific, local url with a web browser then using that as an argument to ‘wget’ (e.g. “wget http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.25.20.tar.bz2”).

    Compiling the Kernel
    (note: should be replaced with the kernel version used e.g.: 2.6.25.20)
    Unpack this by running the command “tar jxf linux-.tar.bz2 && ln -sf linux- linux”, and then run “cd linux” to change to the new folder. We now need the kernel configuration from zeroshell. Copy the file /proc/config.gz on the zeroshell machine to the newly created folder on your module build machine using whatever method you want. I copied it to and from network storage on a 3rd machine using sftp.

    On the module build machine (in the /usr/src/linux folder, which now contains config.gz), run “gunzip config.gz && mv config .config && make -j4 bzImage && cp arch/i386/boot/bzImage /boot/vmlinuz- && make -j4 modules && make -j4 modules_install”. This will take several minutes on a fast machine, and the ‘4’ in -j4 should be the number of CPU’s in your build machine.

    Set up boot entry
    Now you need to create a new initram image, which I was able to do with “update-initram -c -k “. Finally, unless you’re running grub2, you’ll need to edit “/boot/grub/menu.lst”. It needs an entry for your new kernel. The easiest way is to duplicate the first entry (which begins with the keyword “title”) and edit your new first entry. The vmlinuz and initrd file names need to be updated to reflect the names of your newly created files, which are both in the /boot directory. If you don’t know an editor, you can probably use mcedit, nano, pico, or joe. Here is my entry:

    title           Ubuntu 9.04, kernel 2.6.25.20
    uuid 77b2642d-59df-47dd-86c8-62590146519d
    kernel /boot/vmlinuz-2.6.25.20 root=UUID=77b2642d-59df-47dd-86c8-62590146519d ro quiet splash
    initrd /boot/initrd.img-2.6.25.20
    quiet

    Build vmware modules
    Once you save the file and quit the editor, you’re ready to reboot (the command is “reboot”) and install the vmware-tools package. The new entry is probably now your default, but you may need to select it from the boot list. Install the vmware-tools normally. The new kernel modules will be located in /lib/modules//misc and need to be copied to your modules folder on zeroshell (/Database/rootfs/modules). Run the command “cd /lib/modules/ && tar jcf misc.tar.bz2 misc”. This will generate a file misc.tar.bz2, which needs to be copied to the same kernel module folder on zeroshell (/Database/rootfs/modules//) and extracted (“tar jxf misc.tar.bz2”).

    Installing vmware-tools also modified some of the files in /lib/modules/2.6.25.20, which I didn’t copy over to zeroshell. However, I’m not sure if it’s safe to copy them over to zeroshell. I didn’t check to see if the files on Ubuntu matched what is on Zeroshell before I installed vmware-tools, and I’m too tired to do this again. Without these changes, the modules aren’t properly installed, but they’re still perfectly usable. If the forum lets me edit this, I’ll check into copying the other files over and update this.

    The modules will need to be loaded as part of the boot script. Here’s my updated script to actually load the modules:

    !/bin/bash
    mount -o remount,rw /

    unlink /usr && /cdrom/usr/bin/ln -s /Database/rootfs/usr /usr
    unlink /sbin && ln -s /Database/rootfs/sbin /sbin
    unlink /lib/modules && ln -s /Database/rootfs/modules /lib/modules

    cp -a /Database/vmware-tools/scripts/etc/* /etc

    for f in /lib/modules/2.6*/misc/*.o; do
    insmod "$f"
    done

    /Database/vmware-tools/etc/init.d/vmware-tools start
    /etc/init.d/netconfig restart

    Are there any plans to merge this into the vmware download, so it’s all pre-installed? At some point, I can clean up the installation and submit a tar of the necessary files to go on the virtual disk (assuming that is legal and there is somewhere to submit them). It would help if I understood the zeroshell boot process better. I don’t know that I’ll be available for much maintenance, but I try to do things well enough that no one gets that job.

    Is there any reason that you put the vmware-tools in a separate folder from everything in rootfs?

    in reply to: OpenVPN Host-to-LAN Mangling Clients’ Routing Tables #50874
    jbo5112
    Member

    I do have an option on my client to ignore any changes to my default route, but I was hoping to change the server to issue correct routing information. I also had to enable the source NAT once I made the changes to the client.

    in reply to: OpenVPN Host-to-LAN Mangling Clients’ Routing Tables #50872
    jbo5112
    Member

    I clicked the net button, and added my office subnet to the list. I now have another necessary entry, but the default gateway is still being changed.

    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.5.0 192.168.250.254 255.255.255.0 UG 0 0 0 tap0

    I’ve tried adding the VPN subnet, checking and unchecking the source NAT button (I’m not sure what it does), disabling and enabling the DHCP settings on the VPN subnet, and I think every combination of each. No matter what I try, the default gateway is changed.

    in reply to: Downloading the CA for Host-to-LAN OpenVPN #50878
    jbo5112
    Member

    Thanks. That works.

    in reply to: Downloading the CA for Host-to-LAN OpenVPN #50876
    jbo5112
    Member

    I’m trying the CA link. If I just click on the link, I get a blank page. Chrome shows it having an empty body, and firefox just has some hint tag in there. If I right-click the link, and save it from the same LAN, I get a copy of the login page. It seems like it should be so simple, and it’s making me feel rather stupid. Is there something I need to do other than just click? I don’t suppose it could be a bug with Release 1.0.beta13.

    in reply to: OpenVPN Host-to-LAN Mangling Clients’ Routing Tables #50871
    jbo5112
    Member

    Thanks! 😀 I guess I didn’t read that popup page carefully enough. I’ve made the changes, and I’ll test it out when I’m at home.

Viewing 11 posts - 1 through 11 (of 11 total)