jstrebel

Forum Replies Created

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • in reply to: Radius MAC authentication (not working as expected) #53394
    jstrebel
    Member

    Hi, I spent more hours to find the root cause, no success.

    I have attached a log file. In this log file I see that the Radius Server does not recognize the MAC address which I expect to be recognized as “User”

    User-Name = “ac:cf:5c:be:45:98”
    I have also tried to change DEFAULT Simultaneous user to 2 in /raddb/user file without success.

    Thank you for your help. Jakob
    Link to the Log file: http://goo.gl/8xQpVL

    in reply to: How can I change Radius logging to "debug" level? #53402
    jstrebel
    Member

    I post the answer, may be it will help others.
    – service radius stop
    – radiusd -X

    in reply to: invalid security certificate after config restore #52614
    jstrebel
    Member

    I deleted the certificates for ZS, no success at all.
    Finally I reinstalled Firefox. This solved the issue.
    jakob

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46591
    jstrebel
    Member

    Could you please explain how you connect the HTC to the Zeroshell?
    Jakob

    in reply to: UMTS options #47229
    jstrebel
    Member

    dimi,

    did you try to send only the PIN code in the Optional AT string?
    “AT+CPIN=xxxxx”
    (the individual APN names for your provider you might get searching with google)
    If you need mor help, it might be helpful if you tell us which provider you are using.

    jakob

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46589
    jstrebel
    Member

    Fulvio,
    I rewrote the Flash Memory again and started again from scratch. The Problem went away.
    Jakob

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46588
    jstrebel
    Member

    Fulvio,
    two UMTS setups where working yesterday. (one for swisscom and the other for sunrise) After this success, I decided to restart from scratch by selecting the default configuration of the zeroshell.

    Initially I was able to connect with two operators. sunrise.ch and swisscom.ch

    With the “new” configuration I can’t connect anymore to the two UMTS networks. comgt – d /udev/ttyUSB0 are indicating the basic connection is up.

    Could you give me a Idea how to trouble shoot this further.
    Thanks Jakob

    root@zeroshell root> comgt -d /udev/ttyUSB1
    SIM ready
    Waiting for Registration..(120 sec max)
    Registered on Home network: “Swisscom”,2
    Signal Quality: 16,99

    But the chat log are indicating the PPP connection is not established.
    I have enclosed two logs (one for Sunrise and the other for Swisscom. (The swisscom Card does not need a PIN code)

    Try to connect to SWISSCOM:

    14:36:20 SIGTERM
    14:36:23 abort on (BUSY)
    14:36:23 abort on (NO CARRIER)
    14:36:23 abort on (ERROR)
    14:36:23 report (CONNECT)
    14:36:23 timeout set to 15 seconds
    14:36:23 send (AT^M)
    14:36:23 expect (OK)
    14:36:23 AT^M^M
    14:36:23 OK
    14:36:23 — got it
    14:36:23 send (AT+CGDCONT=1,”IP”,”gprs.swisscom.ch”,””,0,0^M)
    14:36:24 expect (OK)
    14:36:24 ^M
    14:36:24 AT+CGDCONT=1,”IP”,”gprs.swisscom.ch”,””,0,0^M^M
    14:36:24 OK
    14:36:24 — got it
    14:36:24 send (ATD*99#^M)
    14:36:24 expect (CONNECT)
    14:36:24 ^M

    Try to connect to SUNRISE:

    14:44:01 abort on (BUSY)
    14:44:01 abort on (NO CARRIER)
    14:44:01 abort on (ERROR)
    14:44:01 report (CONNECT)
    14:44:01 timeout set to 15 seconds
    14:44:01 send (AT^M)
    14:44:01 expect (OK)
    14:44:01 AT^M^M
    14:44:01 OK
    14:44:01 — got it
    14:44:01 send (AT+CPIN=XXXX^M)
    14:44:02 expect (OK)
    14:44:02 ^M
    14:44:02 AT+CPIN=XXXX^M^M
    14:44:02 +CME ERROR
    14:44:02 — failed
    14:44:02 Failed (ERROR)

    XXXX stays in both cases for the 4digit PIN code.

    in reply to: Feature request Radius atribute inclusion #45172
    jstrebel
    Member

    Fulvio,
    my apology to ask you about this again.
    Just let me know is the enhancement (increase) of radius attribute list still in your agenda. Since we have now the great UMTS fail over i see value for more flexibility in the Radius authentication.
    Thanks Jakob

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46586
    jstrebel
    Member

    @fulvio wrote:

    Try the command

    comgt -d /udev/ttyUSB1

    to check the SIM is unlocked and has registered to the 3G network.

    Regards
    Fulvio

    Fulvio,
    I had to add
    AT+CPIN=XXXX
    in the options field. Then the ppp connection came up.
    Thanks for your help.
    Best regards jakob

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46584
    jstrebel
    Member

    @fulvio wrote:

    You can find further details about the connection dialog in the [Logs][chat] section.

    Regards
    Fulvio

    Fulvio,
    thanks for your reply. Could you give me a hint what is going wrong when the ZS is trying to open a session.
    I have tried with two different dial strings, the result seems to be the same.
    Regards jakob

    with dial string *99#
    18:50:25 abort on (BUSY)
    18:50:25 abort on (NO CARRIER)
    18:50:25 abort on (ERROR)
    18:50:25 report (CONNECT)
    18:50:25 timeout set to 15 seconds
    18:50:25 send (AT^M)
    18:50:25 expect (OK)
    18:50:25 AT^M^M
    18:50:25 OK
    18:50:25 — got it
    18:50:25 send (AT+CGDCONT=1,”IP”,”internet.sunrise.ch”,””,0,0^M)
    18:50:25 expect (OK)
    18:50:25 ^M
    18:50:25 AT+CGDCONT=1,”IP”,”internet.sunrise.ch”,””,0,0^M^M
    18:50:25 +CME ERROR
    18:50:25 — failed
    18:50:25 Failed (ERROR)

    with dial string: *99***1#

    18:58:45 Failed (ERROR)
    18:58:54 abort on (BUSY)
    18:58:54 abort on (NO CARRIER)
    18:58:54 abort on (ERROR)
    18:58:54 report (CONNECT)
    18:58:54 timeout set to 15 seconds
    18:58:54 send (AT^M)
    18:58:55 expect (OK)
    18:58:55 AT^M^M
    18:58:55 OK
    18:58:55 — got it
    18:58:55 send (AT+CGDCONT=1,”IP”,”internet.sunrise.ch”,””,0,0^M)
    18:58:55 expect (OK)
    18:58:55 ^M
    18:58:55 AT+CGDCONT=1,”IP”,”internet.sunrise.ch”,””,0,0^M^M
    18:58:55 +CME ERROR
    18:58:55 — failed
    18:58:55 Failed (ERROR)

    in reply to: GPRS/EDGE/UMTS/HSDPA router with Zeroshell #46582
    jstrebel
    Member

    Hi, i am totally unexperienced with this UMTS setup. The Huawei 220 is recognised by the beta 11. I followed the description: UMTS-HSDPA-Mobile-Router. My ZS is not able to establish a connection trough the UMTS modem.
    The only thing I see in the log is:
    12:19:11 pppd 2.4.3 started by root, uid 0
    12:19:12 Connect script failed
    12:19:12 Exit.
    Which does not tell me a lot what is going wrong.

    Q: is there a way to get more details in the log?
    I.e what is failing during the execution of the script?
    As APN i did configure internet.sunrise.ch

    Thanks for help

    in reply to: New release #47002
    jstrebel
    Member

    Hi Fulvio,
    thanks for the great work you are doing.
    Could you please give a hint wich UMTS / GPRS Modems you are expecting to work with ZeroShell? USB connected for example?
    Best regards
    Jakob

    in reply to: Feature request Radius atribute inclusion #45171
    jstrebel
    Member

    Fulvio,
    thanks for the good news. I think this is a great project you are driving ahead.

    Jakob

Viewing 13 posts - 1 through 13 (of 13 total)